Java Primality Test Hacker Rank Solution

Hello coders, In this post, you will learn how to solve Java Primality Test Hacker Rank Solution. This problem is a part of the Java programming series.

One more thing to add, don’t straight away look for the solutions, first try to solve the problems by yourself. If you find any difficulty after trying several times, then look for the solutions.

Java Primality Test Hacker Rank Solution
Java Primality Test Hacker Rank Solution

Java Primality Test Hacker Rank Solution

Problem

A prime number is a natural number greater than  whose only positive divisors are  and itself. For example, the first six prime numbers are 2,3,5,7,11 and 13 .

Given a large integer,n , use the Java BigInteger class’ isProbablePrime method to determine and print whether it’s prime or not prime.

Input Format

A single line containing an integer,  (the number to be checked).

Constraints

  • n contains at most 100 digits.

Output Format

If n is a prime number, print prime; otherwise, print not prime.

Sample Input

13

Sample Output

prime

Explanation

The only positive divisors of 13 are 1 and 13, so we print prime.

Java Primality Test Hacker Rank Solution

import java.io.*;
import java.math.*;
import java.security.*;
import java.text.*;
import java.util.*;
import java.util.concurrent.*;
import java.util.regex.*;
public class Solution {
private static final Scanner scanner = new Scanner(System.in);
public static void main(String[] args) {
BigInteger n = scanner.nextBigInteger();
System.out.println(n.isProbablePrime(1) ? "prime" :"not prime");
scanner.close();
}
}

Disclaimer: The above Problem (Java Primality Test) is generated by Hackerrank but the Solution is Provided by Chase2Learn. This tutorial is only for Educational and Learning purposes. Authority if any of the queries regarding this post or website fill the following contact form thank you.

Sharing Is Caring